Is GuardedID® compatible with macOS Sierra / High Sierra / Mojave?

The current version of GuardedID® for Mac is compatible with OS X 10.10 (Yosemite) - macOS 10.14 (Mojave).

If an update for GuardedID® is available for your system, you will receive a notification from the GuardedID® application upon restarting it.

  • 79
  • 28-Feb-2019
  • 4493 Views