Is GuardedID® compatible with macOS Sierra / High Sierra?

The current version of GuardedID® for Mac is compatible with OS X 10.10 (Yosemite) - macOS 10.13 (High Sierra).

If an update for GuardedID® is available for your system, you will receive a notification from the GuardedID® application upon restarting it.

  • 79
  • 12-Sep-2018
  • 3075 Views