Is GuardedID® compatible with macOS Sierra / High Sierra / Mojave / Catalina?

The current version of GuardedID® for Mac is compatible with OS X 10.10 (Yosemite) - macOS 10.15 (Catalina).

If an update for GuardedID® is available for your system, you will receive a notification from the GuardedID® application upon restarting it.

  • 79
  • 04-Dec-2019
  • 5110 Views